APRSmap Release notes

Aus OE Wiki
Wechseln zu: Navigation, Suche
  • libpng und libz statisch dazu gelinkt
  • font symbol und OSM karten nun im png Format
  • 4 Kursortasten zum Karteverschieben und Backspace für letzte Position(en) (sofern die bei allen x11 gleichen hexcode haben)
  • OSM Karten in Unterverzeichnissen nach Zoom Faktor 1..16 vorhandene maps löschen oder einsortieren
  • wenn Files fehlen wird sofern vorhanden die mit dem nächste Zoomfaktor gedehnt eingesetzt
  • ./gm.sh starten bzw anpassen nach Bedarf zum Kartenholen
  • linke Maus auf Karte klicken oder auf Track oder Symbol öffnet Menü, viele Funktionen mit Klick erreichbar aber noch nicht alle Menüs, noch chaotisch aber mal zum Testen
  • Wettergrafik + statistik auf x11 abrufbar
  • ESC taste zum Menüsschliessen
  • Funktion der Klicks auf symbol/text/map/track getrennt konfigurierbar
  • 5 watch calls (ohne wildcard) statt "follow car"
  • Wwettersymbol etwas besser anklickbar (symbols.png) (alpha Kanal nach heller verschoben, sollte mal nach 255 wenn alle Symbole dafür adaptiert)
  • rechte Maustaste = BACKSPACE (back in zoom/pan-history) (bei www Version lokal back am Browser)
  • map move steps teil der Fenstergrösse


6.1.2013

  • Marker auf "Next click to Map": ohne Einrasten auf Symbole "Next click to Symbol oder Text": mit Einrasten auf genaue Position wenn vorhanden
  • Marker löschen und keycode "@"
  • zoom to markers wieder da "Y"
  • kmh Histogramm und Animation entsprechend der eingestellten Sichtbarkeitszeit des Tracks
  • blaue popup Menüs sortiert nach der Größe angereiht von links oben
  • "Expandes Tiles" geht auch weg wenn alle tiles 1:1
  • call in die watchlist mit click


7.1.2013

  • Taste "@" umgewidmet auf "on click" Reset
  • Taste ":" löscht beide Marker
  • 30s langer Retry Mechanismus zum Tiles Laden, sobald "gettiles" gelöscht, je Sekunde 1 Ladeversuch aller benötigten oder expandierter Tiles und was fehlt oder "png error" hat wird erneut im "gettiles" angefordert.


7.1.2013

  • Tasten "<" und ">" entsprechend "Debug Track" raw+decoded Text der Waypoints oder Baken durchsteppen und setzt Marker 1
  • Backspace history size 20 statt 10


10. 1. 2013

  • Tasten < > getauscht und Textinfo bleibt sichtbar
  • Click to WxSymbol neu und dort dann entweder 1 nicht-Wetter Messwert oder beliebig viele Wetterwerte zugleich ein/aus schaltbar (Menü bleibt offen)


14. 1. 2013

  • Letzter Wettermesswert in der Kopfzeile der Wettergrafik
  • Wettergrafik passt sich der Fensterbreite an (ab 320 Breite)
  • Raw+Decoded Fenster bleibt trotz "Marker to Klick" Messdaten Fenster offen


16. 1. 2013

  • Decodiert positionless WX Daten
  • Decodiert negative NN im "/A="-Format
  • Zoom to Markers geht auch bei Zoomlevel>14
  • Fractional Map Zoom rechnet etwa 2x so schnell und richtiger
  • Shift-Taste bei Map Move macht 1/10 Schrittweite
  • Shift-Taste bei Zoom (derzeit nur mit Maus) macht 1/10 Zoom Schritte


20. 1. 2013

  • Klick auf Track mit Raw+Decoded für den Geklickten Wegpunkt
  • Raw+Decoded mit Wegpunkt Nummer / Gesamtpunkte zur Orientierung wo man ist
  • Cut + Paste Puffer wird mit angeklicktem Call gefüllt
  • Paste in Texteingabefelder
  • leider geht beides nicht nach aussen weil die Fenster heute mit "selections" miteinander telefonieren und das ist etwa so aufwendig wie das gesamte Interface zum X11 bis jetzt
  • (derzeit noch nicht ein/ausschaltbares) Textfenster mit Scrollbalken für lange Texte. Zum Test mit Rawdaten von tcp connect.
  • nach 4 Tagen Suche noch nicht gefunden wie man Kill des Fensters abfangen kann ohne dass dabei alles abschmiert. Da auch die ganzen Xlib Aufrufe zum Text reinzeichnen keiner auf Windoof/sontswas portieren wird, wirds wieder abgeschafft.


26. 1. 2013

  • Textfenster mal wieder weg
  • rawlog File wird nun auch nach dem Einlesen geschlossen und wie bisher beim Schreiben für jede Zeile neu geöffnet
  • Marker 1 zu klick misst, wenn genau 1 Objekt mit klick erfasst wird mit Einrasten auf dieses, wenn "on next click set marker 2" immer ohne Einrasten


3. 2. 2013

  • (minimierbare) fixe Toolbar (die minimierte verdeckt noch manchmal Text Messages)
  • Popup Menüs ausgemistet, z.B "Show All" nur wenns nicht schon ist
  • Von den neuen Kommandos aus der Toolbar gehen erst ein paar wirklich (W V Q S) Messages, Listen, Config noch nicht


6. 2. 2013

  • Fahrtrichtungspfeil + Windfahne bei Wx Symbol, 20kmh pro Strich beides als Teil vom Symbol anklickbar und abschaltbar


10. 2. 2013

  • Auswahl ob Toolbar oder Popup Fenster, damit beim Start normale Toolbar da ist. Muss noch optimiert werden was in welchem Menü sein soll und was offen bleibt oder verschwindet. Histogramme verdecken die Pulldown Menüs aus der Toolbar
  • Höhenangabe bei den Symbolen, noch nicht abschaltbar weil alle Symbol-Attribute ab einem einstellbaren Wert (mindest meter, km/h) konfigurierbar erscheinen sollten.


13. 2. 2013

  • Text Editor mit Scrollen für Config und (wenn fertig) Messages, Parameter werden erst einzelne ausgewertet
  • Screenshot mit Filename
  • rawlog einlesen mit Filenamen (Datum Eingabe noch nicht ausgewertet)


16. 2. 2013

  • Watch Calls per Click suchen freien Platz in der Liste weil jetzt tastaturlos auch wieder abschaltbar
  • Watch Calls mit * als Wildcard
  • Setzen der Start Map Position auf Bildmitte per Lokator, Long/Lat, oder mit "?" im Config und dann Marker 1 setzen auf der Map
  • eigene Position im Config auch mit "?" mit Marker 1 übertragbar.
  • Config File Speichern/Laden beim Start verwenden und automatisch bei Quit Speichern
  • fehlt noch Auswerten einiger Config Parameter zb Helligkeiten und "next click to Wx"


15. 2. 2013

  • Ausser Igate/Network und LogDatum Configs sollten alle gehen und gekoppelt sein mit den Schiebereglern. Manche Werte, die beim teilweise eingegeben sein Unfug machen, werden erst bei "Save" "Reload" oder Start ausgewertet


28. 2. 2013

+ Bei Click auf Pixel das zu mehr als 1 Objekt gehoert, werden die gefundenen Objekte

 bei jedem weiteren Click der Reihe nach an die 1. Stelle cykliert

+ Logfile Import mit Datum + ganze Stunde

+ Netbeacon aus Configparametern damit per Modem empfangenes ein Symbol fuer MH hat

 (noch nicht per tcp gesendet)


3. 3. 2013

+ Objekte Loeschen

+ Filtern von Call, Igate, Objekt/Item-Absender (erst mal ohne Wildcards)


7. 3. 2013

+ transparente Menues oder schwarzer oder grauer Hintergrund

 (Config Transparency 2..100, 1, 0) 

+ Config Baken Symbol mit Auswahlmenu ("My Symbol" clicken)

+ Objekt loeschen mit DEL-Taste


17. 4. 2013

+ Nach wochenlangem Kampf mit den Windoof Compilern ist nun etwa Gleichstand bei der

 Win32 Version und es kann wieder am gemeinsamen Teil weiter gebaut werden.
 Die innere Struktur ist etwas umgekrempelt zwecks minimiertem systemabhaengigen
 Teil. Leider hat sich die "Tile" Filestruktur (mit schnell mal 3500 Files in einem
 Verzeichnis) am Win als Bremse erwiesen und daher ist noch eine Unterverzeichnis-
 Ebene dazu gekommen und die Struktur nun gleich wie auf den Servern und "Marble".
 Zum Konvertieren der vorhandenen Maps ist das "rentile" script dabei das man
 noch anpassen muss und mit der Kommandozeile, die drin angegeben ist, Aufrufen.
 Es wird nix geloescht nur kopiert. "gm.sh" ist auch darauf angepasst. 

+ Neu sind nur ein paar Filter im Config und fuer Besitzer eines Mausrades damit Zoomen

 und Pull der Map mit der mittleren Maustaste. Fuer Touchpad-geschaedigte muss man sich
 noch eine Alternative mit Shift/Alt oder Klick auf die leere Map ausdenken. 
 Screenshot geht nun auch als "bmp" wenns File .bmp heisst.


17. 4. 2013

+ Pull Map auch mit linker Maustaste auf leere Map (configurierbar ?)

+ Shift + Click to Map: Set Marker 1 (configurierbare andere kommandos ?)

+ On next Click to Wxsymbol: Raw+Decoded zu den Wettergrafiken dazu einschaltbar


20. 4. 2013

+ tcp Connect zum Server mit neuer Syntax, -g <ip>:<port>[#<filter>] -g 44.143.100.1:14580#m/300

 MYCALL und PASSWORT jetzt schon aus dem Config statt -s -p 

+ Netzbake: "File" > "Config" -> Mycall, MyPos, Net Beacontext, My Symbol,

            Netbeacontime mit Enable, PassCode mit Enable
            My Symbol Anklicken fuer Auswahl
            My Position "?" an 1. Stelle und dann Marker 1 Setzen 


29. 4. 2013

+ tcp Connect nun probisorisch im File>Config, wenn man editiert gruen ausschalten und wenn

 fertig wieder ein.
 

+ auf Wunsch Massstab auf der Karte (noch nicht schaltbar) und auch problematisch wegen

 nicht entfernungstreuer Merkator Karten bei kleinem Zoom


4. 5. 2013

+ Vorschlag von dl8rdl eingebaut, Maps Download im Hintergrund komplett fuer das sichtbare

 Fenster von Zoom 1 bis einstellbarem maximalen Zoom mit Vorkalkulation der Datenmenge,
 abbrechen, weitertun, und Fortschrittsanzeige.

+ Messages empfangen (derzeit erst von tcp)


6. 5. 2013

+ "DAO"-Erweiterung in Frame-Decoder eingebaut zum Position auf etwa 20cm genau uebertragen

 und auch genauere Auswertung vom GPS-raw-Format und Anpassung der Rundung auf Feldmitte
 (leider ist die fliesskomma Genauigkeit nur etwa 1-2m)


8. 5. 2013

+ Mehr Status Meldungen von "on/off" Schaltern und (Shortcut) Funktionen

+ <Make Video> legt "map.y4m" auch auf Linux neu an wenn nicht (zB. als named-pipe) vorhanden,

 meldet Schreibvorgang, refresht alle 1s den Bildschirm und ist abbrechbar.

+ Buttons mit noch nicht implementierter Funktion melden das.

+ Im Screenshot Filenamen wird "%t" durch Datum-Uhrzeit und %n durch "000" bis "999"

 ersetzt bis der Filename neu ist.

+ Shortcut Tasten Liste im <Help>


10. 5. 2013

+ 4 direkt waehlbare Map Positionen + Zooms im Zoom-Menue oder per "1..4" Tasten.

 Dabei kann entweder der Zoomlevel oder die Position oder beides abgerufen werden.
 Der Eintrag dieser "Views" kann manuell im File>Config>View durch "Zoomfaktor Position"
 (wobei Position auch ein QTH-Lokator sein kann), oder eines von beiden, oder viel
 schneller durch "Shift" + Click auf einen der 3 "Views" im Zoom Menue erfolgen.
 Dabei wird die aktuelle Karten-Position mit Zoom gespeichert.
 Shortcuts anders: "1" (one user) nun "."
                   "2" +rf        nun "="
 "On next click" neu einstellen erforderlich
            

12. 5. 2013

+ Tooltipps mit Text aus externem File "hints.txt" und schon etlichen Texten drin.

 Darf natuerlich verbessert oder uebersetzt werden wobei das Ergebnis der Arbeit
 sofort aktiv ist sobald das hints.txt gespeichert ist.
 |Buttonnummer Text
 die fehlenden Texte werden als "<Buttonnummer> hint text" gezeigt
 die Struktur des File>Config wird noch umgebaut daher mit den hints dafuer abwarten


15. 5. 2013

+ "Zitter"-Toleranz fuer Mausposition innerhalb der die Hints sichtbar bleiben + Zeigt aktuelle "Mbytes written" des Video Files + List>Internals zeigt System Zustand + "L" Shortcut nun "toggle Labels on/off" Labels=Text bei den Symbolen + Fine Zoom Steps im Config


17. 5. 2013

+ "L" und "O" bzw "Labels off" "Objects off" wird nun nimmer in Form von 0% Helligkeit

 im Config verewigt

+ In Vorbereitung auf ein Text-Fenster kommt nun mal List>Messages und List>Bulletins

 auf das Start Terminal Fenster raus, wobei die Bulletins noch nach 
 Absender/Eintreffzeit sortiert sind und nicht nach der BLN<nummer>

+ Angeklickte Objekte kann man in Infos>List Raw oder Infos>+Decoded auf das Textfenster

 auflisten lassen (ohne farbige Fehlermeldungen)


18. 5. 2013

+ Config>Show Incoming "n" Zeigt TCP-Frames auf dem Textfenster, "n+" Dekodiert

 fuer die Radio Ports entsprechend 1 2 3 ... und 1+ 2+ ... Dekodiert


21. 5. 2013

+ Raw+Decoded Sprechblase aktualisiert sich mit ankommenden Daten falls sie den letzten

 Wegpunkt anzeigt

+ Delete Waypoint, wenn mit Debug oder Raw+Decoded markiert. Mit DEL-Taste zum entfernen

 von (falschen) Wegpunkten. Marker 1 springt dann zum naechsten (vermutlichen) Fehler weiter.
 (Wann alles loeschen oder nur Waypoint muss noch besser definiertbar sein)

+ Hoehe wird auch bei Symbolen ohne km/h Daten angezeigt falls Hoehendaten vorhanden und

 eingeschaltet.


23. 5. 2013

+ UDP-Port im Config (erst mal 1 Stueck) + Fenstergroesse veraendern schneller + Trackfilter Fehlererkennung verbessert + Bei Debug Funktionen Verzoegerungszeit von doppelten Waypoints in Sekunden sichtbar


29. 5. 2013

+ Zwecks schnellem Tracks Debuggen mit "E" oder File>Infos>Waypoints-Button toggelt

 alle, oder nur die als verdaechtig markierte Waypoints anzeigen mit den "<"">" Tasten
 oder den Buttons daneben. 

+ rawlog mit lesbarem Datum/Zeitstempel, das alte Format wird lesend auch akzeptiert.

+ axudp-kiss (usb)seriell Interface (udpflex) erweitert, sodass nebst an/abstecken von

 usb-Seriellen auch ein resetteter TNC2 an empfangenen (nun nicht mehr kiss) Daten
 erkannt und wieder auf kiss geschaltet wird. Geht mit init File auch fuer andere TNC
 wie in THD7x oder TMD7x. 
 udpflex (linux), udpflex.exe (win32)


8. 6. 2013

+ Configurierbare default Speed fuer Animation + Parkplatzzittern-Erkennung fuer Animation Startzeit verbessert + Source Code Entruempelung zum einfacheren Compilieren fuer verschiedene Prozessoren


15. 6. 2013

+ km/h und/oder Hoehe in Animation und Video wobei Lesbarkeit bei schneller Aenderung

 noch verbessert werden kann.

+ Uhrzeit beim Log schreiben laeuft nun auch waehrend Animation in Echtzeit. + +-24h Zeitversatz Systemzeit/angezeigte Zeit einstellbar


5. 7. 2013

+ Objekte mit extra "keep in memory time" zB um den schon nach 5 bis 6h recycelten

 Blitz-Object-Namen keinen Track erzeugen zu lassen.

+ Logfile browsen geht gleichzeitig mit online Betrieb. Dazu wurde eine zweite

 Uhrzeit geschaffen die den Logdaten folgt und die Echtzeit Daten werden unabhaengig
 von den Logdaten (wie sonst auch) im RAM und writelog gepspeichert.
 Es kann jederzeit zwischen Log und Echtzeit gschalten werden und in den Logdaten
 an Anfang, Ende, und in "Fullbright" Zeitspruengen vor und zurueck gegangen werden
 womit immer alle Daten einmal sichtbar sind.

+ Status Bar zeigt Betriebszustand, erst mal experimentell zum sehen was man braucht

 mit Buchstaben bis Symbole entworfen sind. Bei TCP (Internet) und und UDP (Funk)
 wandert die Farbe von gruen nach rot binnen 1 Min. solang keine Daten ankommen.
 Message soll mal anstatt dem Popup Fenster vorhandene Messages anzeigen und erst bei
 draufklicken Inhalt zeigen.


16. 7. 2013

+ Hoehen Diagramm ueber Wegstrecke, mit Trackfiler on "F" wird versucht die manchmal

 ungenaue Hoehenmessung etwas glatt zu buegeln.

+ Beim Track anklicken wird der Wegpunkt ausgewaehlt der der Klickpunkt am naechten

 liegt.

+ Popup Meldungen, die Befehle bestaetigen, werden nach ein paar Sekunden wieder

 entfernt. Da, um CPU Zeit zu sparen, der Bildschirm nur aktualisiert wird wenn neue
 Daten kommn, geschieht das Loeschen nur im Zuge einem Updates.


19. 7. 2013

+ "On Next Click To Track" mit Speed oder Altitude aktiviert, setzt eine Marke auf

 dem Diagramm, die der angeklicken Stelle am Track entspricht.

+ "On Next Click To Track" kann mit 1 Click Wegpunkt loeschen aktivert werden.

+ Ein angewaehltes Objekt kann mit "Save" als Logfile mit dem Filenamen des Objekts

 gespeichert werden (derzeit nur im Startverzeichnis). Existiert das File, wird
 hinten dran geschrieben. Es werden alle Daten aus dem RAM geschrieben auch wenn
 mit Trackfilter oder Fullbright Time ausgeblendet.
 Manuell geloeschte Baken/Wegpunkte sind weg.


22. 7. 2013

+ Video/Animation Speed Einstellbereich erweitert von 1:1 (Echtzeit) bis 200s/Frame

 womit die Speed-Zahl statt (Echt-)Sekunden zu Frames jetzt multiplikator fuer
 Echtzeit ist.

+ Start Delay fuer beschleunigte Darstellung (wenn sich nichts bewegt) einstellbar

+ Log Import fuer ein Call wobei immer auf eine Zeitspanne gesucht wird in der das

 Call aktiv war (keine wildcards)


25. 7. 2013

+ "On Next Click" mit mehreren Optionen gleichzeitig (wo es Sinn macht).


9. 8. 2013

+ Durch erweitern der Menue-Darstellung auf Tabellen mit Farben und verbessern des

 Zeilen-Editors (Maus kann Cursor setzen ...) ist Messages erstellen und verwalten
 moeglich geworden. Empfangene Messages sind noch ohne Tabelle.


2. 9. 2013

+ Nach komplettem Umbau des Konfigurations-Tools mit dynamischer Anzahl der

 Eintraege geht nun Messages senden, mehrere Aprs-Server-urls die abgeklappert
 werden bis einer antwortet, beliebig viele Watchcalls, Filtereintraege, Baken...
 Der Texteditor kann Insert/Overtype und Cursor setzen mit der Maus.
 Mit Shift-Linksklick auf die Karte wird die Position in die Editorzeile
 kopiert (jetzt einfach wiederholbar bis man "getroffen" hat)
 (Die eigene Position und die Zoom>"Views" muessen neu eingegeben werden)

+ Die aktuelle Fenstergroesse wird im Konfigfile mit gespeichert.

 "View 1" wird beim Programmstart dargestellt.
 (speichern der aktuellen Ansicht mit Shift-Linksklick im Zoom-Menue)

+ Nach der Frage "was brauch ich alles um online zu gehn" ist dies nun in

 einem Menue. Dabei kann man abgestuft von ganz ohne Call bis Call und eigene
 Position nur dem Server sagen (zwecks funktionieren der m/... Filter) bis
 Bake und Messages ins Netz senden konfigurieren.

+ Igate-Funktion ist nur in der Linux Version vorhanden da das Win-tcp-System

 keine Info ueber bestaetigte Daten hat und dann einen als "haengend" erkannten
 Link nicht terminieren kann, ohne die veralteten Daten noch rauszuweinen.
 Das waere im aktuellen AprsIs-Netz ohne Timestamps nicht mehr akzeptabel. 
 Auch die Linux Igate-Funktion sollte auf keinen Fall fuer einen Digi verwendet
 werden da zB. beim Logfiles durchsuchen die Durchlaufzeit erheblich werden kann.
 Fuer Igate gibts ohnhin ein eigenes Tool.

+ UDP-Ports fuer Funk rx/tx mit Soundmodem oder mittels "udpflex" (USB)seriellen

 TNC gibts derzeit 4. Eine dynamische Anzahl braucht noch Aufwand bei den
 Schaltknöpfen in den Menues.
 
 Der Funk-Baken/Objekt/Items-Editor ist noch in Entwicklung, dort dann auch
 wieder die verschwundene "Rfbeacomtime" fuer jede Bake extra. 
 (bis da hin 1 Bake manuell ins aprsmap.cfg) 



4. 9. 2013

+ Baken senden mit Macros fuer Uhrzeit und File einfuegen (Wetterbake). Jede Bake

 mit Port und Intervall Angabe und Zielport geht auch Net. Mit Beacons Shift Time
 wird die Startzeit jeder weiteren Bake so verschoben, dass sie nicht innerhalb der
 "dupe delete" zeit (meinst 57s) der Igates landen.
 Syntax: intervall(s):port:rawformat 600:1:NOCALL>CQ:>test  
 \\z tag+zeit, \\h zeit, \\:filename:, \\\ \\


8. 9. 2013

+ Maus Hint Texte verbessert und deren Erscheinen an der Status Bar. + User Infos erweitert, gefahrene km, Zaehler fuer Baken, Messages, Acks, Rejects


9. 9. 2013

+ "Show Objects of Sender" zeigt alle (anderen) Objekte und Items von dem Absender

  des Ausgewaehlten Objekts auf einer dafuer gezoomten Karte unter "Info>Objects of.."

+ Shift-Click auf die Status-Bar (die bunten Laempchen) oeffnet direkt das zugehoerige

 Config-Menue soweit Sinnvoll.


11. 9. 2013

+ Menue Positionierung korrigiert und Menues nimmer schliessen bei Shift-Click

 auf Map zum Position in Editor Zeile kopieren


13. 9. 2013

+ Statusbar Netzwerk-Buttons Mouse-Over wenn nicht online normale Hints,

 wenn online, Status Info. X/N zeigt offline/online (sollten mal Symbole werden)

+ "w" Temperatur-Karte wie bisher, "W" (w mit Shift) Regen-Karte mit blau fuer

 24h und rot fuer aktuellen Regen (noch ohne Fehlerfilter, luegende Stationen
 anklicken und mit DEL entsorgen).


16. 9. 2013

+ Logfile lesen mitn Binaersuche fuer den Anfang ab wo ins RAM eingelesen wird

 mit dem Vorteil, dass auch lange Logs beim Programmstart und Log Import schnell
 nach Datum durchsucht sind, aber das Logfile muss nach Datum sortiert sein.
 Derzeit max 4GB Logfile.


19. 9. 2013

+ Message (Query) Kommandowoerter + Antworten in Config > Rf-Ports.

 Standard Querys (?APRSP) als auch beliebige Woerter koennen definiert
 werden und in der Antwort Macros wie \\h Uhrzeit, \\p Path, \\l Position,
 \\v Programm Version, \\<filename> File senden, \\>filename> schreiben,
 letzteres zum aktivieren von einem Programm zum was Steuern oder Sprachausgabe
 "TALK:\\>/tmp/talk.txt>Text um \\h Gesprochen!"
 "?HELP:?APRSP, ?VER, TALK"


22. 9. 2013

+ Windfahne und Temperatur beim Symbol mit Timeout. + 1 Kommastelle mehr bei Koordinaten-Ausgabe und bei Maus-Koordinaten

 Grad/Minuten/Sekunden-Schreibweise zuaetzlich.

+ Win32: bei der (oder mehr) Start-Fenstergroesse die der Bildschirm kann,

 "Maximized" Fenster.


7. 10. 2013

+ Filesystem auf "Longfiles" umgestellt damit sollte Logfile >2GB geschrieben

 und dank Binaersuche auch flott importiert werden koennen.

+ Programm Starter fuer Maps-Downloader bei Bedarf (gm.sh bzw gm.bat)

 der kann sich nach getaner Arbeit beenden. Status in der Status-Bar
 mit "D" statt "E" fuer Downloader laeuft erkennbar.

+ Beliebige Map-Typen configurierbar mit korrektur der Basis-Helligkeit,

 die ersten 3 wie gewohnt mit Shortcut "7" "8" "9", die 1. beim Start aktiv.
 Sat-Maps erst wenn ein JPEG-Dekoder vorhanden ist (ausser man wandelt
 sie beim Download in PNG). Neu (voreingestellt): cyclemap


11. 10. 2013

+ Wegstrecken Summe (ohne Track) auf der Map (shift-click, click, click...) + Log Import (bis auf Suche rueckwaerts nach Call) bei unsortiertem File

 versucht etwas zu verbessern


13. 10. 2013

+ Schriftgroesse einstellbar (Config > Map Paramter > Font Size)


15. 10. 2013

+ Screenshot auch als ".png" (vorerst nur Linux Version)

 und osm-Verzeichnispfad wieder configurierbar

+ "On next click to Track" bei mehrfacher Auswahl mit "Zoom to" wird erst gezoomt

 und dann im 1 Track Mode die anderen Funktionen aktiv.


31. 10. 2013

+ Beep-Sounds mit beliebiger Frequenz und Dauer wenn Message oder Ack eintrifft,

 wenn sich wer in den Warnradius bewegt mit steigender Frequenz und/oder Dauer
 je naeher er zum Zentrum kommt und wenn ein Call aus der Watch Liste aktiv wird.
 Alle getrennt schaltbar und limitiert auf maximal alle 5s.
 Windoof 7 oder 8 geschaedigte koennten evtl. keinen Piepser haben dann gibts als
 Ersatz 3 System-Sounds (mit 0ms einschalten, bis 500, bis 1000, ab 1000Hz
 jeweils ein anderer Gong).
 Config > Map Moving > Bell/Sound


6. 11. 2013

+ In Animation und gedimmten nicht-movern wird die schrift der "mover" im

 nun Vordergrund gehalten

+ Einfaches Hyperlink Hilfetext System mit File "help.txt" unter "Help"

 erreichbar mit ein bisschen Text als Beispiel


18. 11. 2013

+ Einstellbarer Timer zum Verzoegern vom Mapdownload Start waehrend Karte

 verschieben, wer so vermeiden will, dass in hohem Zoom der Streifen an Karten
 entlang der Bewegung durch die Botanik geladen wird. Config / Timers

+ Index Taste im Help Fenster

+ Schutz vor ewig loopenden Mapdownloads wenn durch zB volle Platte oder nicht

 identischem Schreib/Lese-Pfad immer die gleichen Karten angefordert werden.
 Kommt ein Kartenteil immer wieder, wird nach ein paar Versuchen 1. nur mehr
 1 Karte angefordert, 2. die Pause zwischen Anforderungen immer Verdoppelt
 und 3. poppt eine Fehlermeldung auf.

+ Copy/Paste hinein ins Program (rechte Maustaste im Textfeld oder ctrl-v)

 (bei linux jetzt mit dem aktuellen "keiner verstehts..." selection-Verfahren)  


22. 11. 2013

+ "Ok" im config-Zeileneditor schliesst das Fenster nach dem Speichern. + Map download Timing (im Fehlerfall) optimiert, dass mit dem in entwicklung

 befindlichen hochgeschwindigkeits-Downloader von oe5krn bei falscher
 Einstellung oder voller Platte keine "Gigabyte" ins Nirvana geladen werden.


28. 11. 2013

+ "B" und "M" (gross) fuer Bakeneditor und Message senden

+ Index bei Helptext

+ Umfangreicher Baken/Objekt/Item Editor mit verschiebbarem Fenster,

 Import von vorhandenen Objekten auf der Karte durch anklicken.
 Testen lokal vorm Senden.
 Einmal senden oder mit Timer und Verschiebung der Sendezeiten, dass die
 Duplikatloeschung in den Igates Sendungen mit gleichen Inhalt aber
 verschiedener Frequenz (oder direkt per tcp) im Netz sichtbar laesst.
 Einfaches Fernloeschen von Items und Objects.
 Normal/Mic-E/Compressed mit DAO Erweiterung fuer 20cm Genauigkeit
 (die aber je nach Fliesskommaarithmetik nur etwa 1m schafft)
 mit Bytezaehler der Gesamtlaenge beim editieren der Kommentarzeile zum
 optimieren der Kompressionsart.
 Macros zum Einfuegen von Files zB fuer Wetterbake

+ Query standard Antworten (?APRST ...) vorkonfiguriert mit opt-out wers

 nicht will. Config > Rf Ports > Query Keywords

+ Fehler behoben, Decodieren von Items mit kurzem Label.

 Unsichtbare User wegen keinem oder falschem Symbol (die aber trotzdem
 watch/approxy-piepsen) haben nun Label und Track

+ Listings im "Show 1 Modus" zeigen nun nur was zu dem User gehoert


4. 12. 2013

+ Config > Rf-Ports > Monitor Headline

 Damit kann man 0 bis 20 Calls + Tempertur oder km/h als "Ticker"
 von aktuellen Frames auf der Fenster-Ueberschrift durchlaufen lassen.
 Bei minimiertem Fenster ist das aktuellste Call in der Taskleiste. 
 N> kommt von, N< get ans Netz, 1> 2> Funkports, N- heisst der Frame
 ist entweder in den Callfiltern oder ohne verwertbarem Inhalt.

+ (grosses) "F" Shortcut Find (Call, Locator, Breite/Laenge)

+ Bakeneditor "Draw" schreibt nimmer ins rawlog



10. 12. 2013

+ Calls + Temp,km/h,Hoehe der ankommenden und abgehenden Daten in der

 Fenster-Kopfzeile. Anzahl der Calls Config>Rf-Ports>Monitor Headline.
 Updaterate auf (Mittelwert) 1s limitiert.

+ Maus-Verhalten umgestellt (aehnlich anderen Programmen).

 Linksklick wartet auf Maus-Bewegung (mit ein bisschen Zitter Toleranz)
 und zieht Karte (auch wenn ein Symbol getroffen) oder, am oberen Rand
 angefasst, konnen einige Menues und die Status-Bar positioniert werden
 mit "ankleben" an den Fensterrand und gespeichert in aprsmap.cfg. 
 Beim auslassen der Maustaste, wenn nicht bewegt, wird der normale Klick
 ausgeloest.
 Mittlere Maustaste zieht alles was ziehbar ist und an beliebiger Stelle
 angefasst.
 Rechte Maustaste wie bisher Back-in-zoom-History oder in einer
 Texteingabe "Paste" (falls was im copy/paste Puffer ist)


15. 12. 2013

+ Message Senden nun bis 67 Zeichen wie im Protokoll vorgesehen statt 57. + Umlautwandler auf "Ae Oe Ue ss" (bis mal ein 8 Bit Zeichensatz definiert ist). + Message Eingabezeile geleert wenn die vorherige Message abgeschickt wurde oder

 an ein anderes Call als zuvor gesendet werden soll.

+ Schnelles Zoomen mit Shift-Linksklick und Rahmen um den gewuenschten Inhalt

 aufziehen. 

+ (nur Linux) jpeg-Dekoder fuer Maps wobei erst .png versucht wird dann

 jpeg in .png Filenamen und zuletzt jpeg als .jpg (gm.sh modifizieren).



16. 1. 2014

+ Config / Online / Serverfilter Aenderungen werden bei "Ok" sofort zum

 Server geschickt. (sofern der die "# filter ..." Syntax versteht)

+ mit "<" ">" durch einen Track wandern geht mit gleichzeitig geoeffneter

 Altitude- und Speed-Statistik und zeigt dort die Stelle am Track und die
 Messwerte numerisch.

+ Tools / List neu mit verschieb- maximier-, ikonisierbarem Textfenster

 mit Scrollbalken (und Cursortasten und Mausrad) und nach Zeit und
 alfabetisch sortierbarem Inhalt.
 Es kann Rohdaten und dekodiert listen. Text kann man markieren und mit
 "Paste" in andere Anwendungen kopieren (auch auf Win ohne umstaendlichen
 Dialog). Gibt man in Tools / Find ("F"-Taste) ein Wort ein, werden alle
 gleichnamigen Stellen farblich hervorgehoben zB. "APLM01" oder ein Call.
 Klickt man auf eine Zeile, wird auf der Landkarte die Herkunft gezeigt,
 sofern die Zeile eine Position enthaelt und wenn nicht, die letzte
 bekannte Position vom Absender der Zeile.
 Das Live-Monitor-Fenster fuer empfangene und gesendete Daten hat anstatt
 sortieren "Clr" fuer Inhalt loeschen, es stoppt raufscrollen wenn man 
 mindesten 1 Zeile herunter geschoben hat, und kann mit "u"-Taste an und aus
 geschaltet werden. (Beachten: bei Batteriebetrieb durch den laufenden 
 Bild-Update evtl mehr CPU/Akkuverbrauch)
 Das Aktivieren des Monitors ist, bis eine selbsterklaerende Menue-Struktur
 erfunden ist, noch wie zuvor unter Config / Rf-Ports / Monitor Frames.
 

+ Linux: F11-Taste (bei "seltsamen" Fenstermachern die selber kein Maximieren

 oder dann wieder kleiner machen koennen) toggelt Fullscreen/Normal.

+ Win: Kein extra Textfenster mehr da Listings eingebaut.


20. 1. 2014 (Ver 0.32)

+ Funkport (Soundmodem / udpflex) Kommandozeile in Config / Rf Ports /

 Serial Interface
 Task wird automatisch gestartet.

+ Monitor Ports off/raw/decoded einzeln mit Klick schaltbar Tools/List/Monitor.


3. 2. 2014 (Ver 0.32)

+ Message Rx: Schalter fuer Pop-up Fenster

             Schalter fuer zeigen von Messages an andere SSID
             Schalter fuer Messages an sich selber weg filtern (default on)


6. 6. 2014 (Ver 0.34-testversion)

+ Höhendaten (soweit in einem Datenfile vorhanden)

 bei "show Location of Mouse" "on" werden m ueber NN angezeigt 
 ebenfalls neu, Distanz und Winkel zum Marker 1 wird angezeigt
 Files zum selber besorgen:
   osm/srtm3/N48E012.hgt  
             N48E013.hgt
             ...
    (90m aufloesung, 1x1 grad 2.8MByte pro File
    http://dds.cr.usgs.gov/srtm/version2_1/SRTM3/Eurasia/)
   osm/srtm30/W020N90.DEM
    (900m aufloesung, 20W..20E, 40 bis 90N 57Byte, deckt den Rest ab 
    http://dds.cr.usgs.gov/srtm/version2_1/SRTM30/)
   osm/eudem/ (noch nicht implementiert)
    30m Aufloesung, 640MByte fuer 5x5 grad, braucht aber erst konvertierprogramm
    vom (unbrauchbaren) "eu-geotiff" in lesbares Format
    http://www.eea.europa.eu/data-and-maps/data/eu-dem#eeaEsriMap

+ Radiolink Berechnung zwischen Marker 1 und 2 nach Eingabe von Antennenhoehen

 und Wellenlaenge. Vorerst mal Darstellung auf der Map als farbige Fresnelzone
 "blau" frei, "gelb" bis "rot" von angekratzter 1. Fresnelzone bis voll verdeckt. 

+ Radiolink mit 2 Klicks oder fuer tastaturlose Bedienung

 "On next click to Map" mit "Set Marker 1" beim 1. Klick und Marker 2 bei weiteren
 Klicks nach "Clear Markers" wird wieder erst Marker 1 gesetzt.

+ "d" Shortcut fuer Map downlod on/off

+ Map download auch wenn auf "off" wenn "Reload" oder die Download funktion

 betaetigt wird.

+ Testweise "High Resolution Track" Dekodierung als Protokollerweiterung eingebaut.

 Dabei werden mit einer Bake 2 bis 30 Positionen gepackt als Abweichung von einer
 Geraden 2 oder 3 dimensional + Timestamp uebertragen. Wird die Erweiterung nicht
 erkannt bleibt die normale Position pro Bake. 
 Die Optionen sind erweiterbar, Positionsaufloesung, End-zu-End Pruefsumme,
 "QRV"-Frequenz, direktgehoert von Igate, Climb-Rate und fuer Wanderer hoehere
 Geschwindigkeitsaufloesung sind mal vorgesehen. Traegt sich der direkthoerende
 Igate ein, wird vom AprsIs-Service eine veraenderte Kommentarzeile erkannt und
 damit ALLE Igates ersichtlich, die direkt gehoert haben und nicht nur der mit
 der schnellsten Glasfaser Anbindung. Dekodiert wird dabei eine in vom Empfangsmodem
 in Klartext umgesetzte Darstellung fuer AprsIs. Am Funkweg wird binaer und wesentlich
 kleiner gepackt übertragen.


13. 6. 2014 (Ver 0.35-testversion)

  • osm/srtm1/N48E012.hgt mit 30m horizontaler Auflösung aus den EU-DEM Daten umformatiert in das srtm1-Format wird bevorzugt verwendet.
  • UDP-Ports restarten sich wenn beim Editieren was verändert wurde.
  • Map Loader startet beim enabeln ohne nochmal herumzoomen.
  • Speed/Altitude/Gelaendeschnitt-Diagramm updatet sich mit ankommenden Daten wenn mit letztem Wegpunkt oder Symbol anklicken geöffnet.
  • Igate (Rf to Net, nur Linux) jeder UDP Port kann einzeln freigeschaltet werden
  • Geländeschnitt, Darstellungs-Versuch mit zusätzlichem Freiraum-Diagramm auf der Landkarte. Praktisch zum Zoomen aber evtl. missverständlich da nur die Fresnel-Zone zur Karte passt und folglich die Punktreihe, die die Bodenhöhe darstellen soll, nicht.


17. 6. 2014 (Ver 0.35-testversion)

  • Sichtweiten Farbkarte, mit Marker 1 oder 2 oder beiden gesetzt, wird mit "R"-Taste die optische Sichtweite dargestellt. Antennenhoehen am Marker ist 1. Wert in "Tools/Radiolink" am andern Ende gilt Wert 2. Die Wellenlaenge wird hier auf 0 gesetzt und damit ist ab halber Fresnelzone "Sicht". Farbhelligkeit in "Config/Map Parameter/Brightness Rfpath" Die Berechnung ist noch experimentell und sollte nach optimierung deutlich schneller werden und damit man die Landkarte noch lesen kann brauchts noch Darstellungs-ideen.


28. 6. 2014 (Ver 0.37-testversion)

  • Marker setzen mit Einrasten auf die genaue Position eines angeklicktes Objekts (More Infos> ) und ohne Einrasten im Zoom Menue. Dort auch Marker einzeln löschbar. Marker 1 als "hart (gelb)" oder "weich (blau)", letzerer entsteht durch einfaches Anklicken, bewegt sich mit fahrenden Objekten bzw. huepft auf neu angeklickte Objekte oder Wegpunke und hat ein Timeout. Harter Marker bleibt bis löschen.
  • Netz/Funkport Status-Laempchen zeigen nun letzte Sendung (gelb) und letzten Empfang (grün) seit 60s als Sanduhr.
  • Mausrad (oder Zoom-Menue +/- mit Shift) Zoom Stufen (Config/Map Moveing/Fine Zoom Steps) rastern nun die automatischen Zoomvorgaenge auf die eingestellten Werte insbesondere auf "1" also original Osm-Stufen.
  • Ausgeschaltete Tracks (Helligkeit auf 0) machen nun auch Funkwege und Zoom auf das was man noch sieht.


1. 7. 2014 (Ver 0.38-testversion)

  • Watchliste neu mit Schalter fuer Pieps / Landkarte mitbewegen / Logfile zB. mit OE* getrennte Logfiles fuer jedes Call mit OE vorn schreiben.
  • Shift-Click auf Rf-Port-Knopf geht direkt in Config-Editor.
  • Portname nach dem Port-URL zeigt in "i"-Liste und beim "Hovern" auf den aktiven Portknopf Namen und ip Nummer.
  • On Next Click to Track mit "Zoom to" schaltet erst in den 1 User Modus und tut dann (nun hoffentlich) die anderen aktivierten Dinge.


3. 7. 2014 (Ver 0.38-testversion)

  • Baken sollten sichn nun auch mit den "\\" Macros wieder in den Editor laden lassen ohne dass diese expandiert werden. (Vorhandene Objekt-Baken neu eingeben)
  • Message Routing verbessert mit automatischer "NOGATE"-Option wenn nur Funkports verwendet werden
  • Message und Baken Sende-Meldung und Rueckfrage wenn man (meist versehentlich) Leerzeilen Msg senden will.


4. 7. 2014 (Ver 0.38-testversion)

  • Logfile loeschen bzw. Filegroesse anzeigen
  • Etwas mehr "On Next Click"-Optionen kombinierbar


8. 7. 2014 (Ver 0.39-testversion)

  • WX grafik zeigen auch wenn WX Baken ohne WX Daten dabei sind
  • Schalter fuer nur WX-Stationen auf der Karte zeigen


17. 7. 2014 (Ver 0.40-testversion)

  • Nur WX Stationen auf der Karte Zeigen
  • Relief Karten rechnen mit Fortschrittsanzeige und nach 4s Abfrage auf Abbruch (mit srtm(1) Files (Netzwerk-Laufwerk zu langsam) und noch ohne Antialiasing was ab zoom 12 sichtbar wird) map parameter/brightness rfpath zB. "30 100 50 100 80 20 0 100 100" (der 3. Wert 0 fuer harten Kontrast/Funkreichweite oder 500 für aufpeppen von osm-Karten) tools/radiolink "2000 0 0 200" marker 1 und evtl marker 2 setzen und "R" "config/brightness map" zum ein/ausblenden der osm karte)
  • Digipeater (abgespeckte udpbox derzeit noch ohne klicker-Editor und nur grob getestet) Config/Rf-Ports/Digipeater, derweil Internes Format mit Zeileneditor bearbeiten.
  • Message Sendetaetigkeit-popup-Meldungen verfeinert und korrigiert


18. 7. 2014 (Ver 0.40-testversion)

  • der Logfile-Pfad fuer das rawlog wird auch fuer die Watchcall-Logs verwendet


19. 7. 2014 (Ver 0.40-testversion)

  • Watchcall-Liste nach "longest-match" durchsuchen. "OE0AAA" passt bei * OE* OE0* OE0B* auf OE0* OE* +log / OE1X +log / OE1* nichts / OE5A +beep schreibt log von oe ausser oe1 und oe5a aber schon oe1x und peept bei OE5A
  • Call-Log Filegröße anzeigen und Files löschen


20. 7. 2014 (Ver 0.40-testversion)

  • Cursor Up/Down Tasten in mehrzeiligen Textmenues
  • Tasten Fokus Lock auf Eingabefeld nach Anklicken oder Tastatureingabe
  • 1. Klick auf eine Zeile verändert nicht die Kursorposition


25. 7. 2014 (Ver 0.41-testversion)

  • Digipeater, mit fein dosierbaren Standard (mach QRG voll) bis "sehr beruhigt" Optionen
  • Editor dazu Config / Rf-Ports / Digipeater und "Hints"


28. 7. 2014 (Ver 0.41-testversion)

  • Farbe fuer Schrift, Menues, Hintergrund, Transparenz, Radiorange, Reliefkarte mit Farbauswaehler (der noch 3eckig werden soll damit umgekehrt auch eingestellte Farbe drauf gezeigt werden kann)


31. 7. 2014 (Ver 0.42-testversion)

  • Statusknopf zeigt durchgehend wenn Wx/Temp./Regen/Radiorange oder single User Modus ist und kann da ausgeschaltet werden.


24. 8. 2014 (Ver 0.42)

  • "F"ind auf einen sonst unsichtbaren Objekt-Sender zeigt dessen Objekte.
  • "More Infos" zeigt Button "Objects of Call" wenn Call Objekte sendet.
  • Wx-only mit "L"abels off zeigt nur Temperatur und Windfahne beim Symbol.
  • Antennenwinkel bei Geländeschnitt Info.
  • "DUPE" Meldung bei Wegpunkt-Info nimmer "ewig" bei einer Fixposition nach einem Ausreisser.


26. 8. 2014 (Ver 0.42)

  • ip-Nummer Schreiberei vereinfacht, "127.0.0.1" kann weggelassen werden
  • udpflex erweitert auf "net-kiss", also kiss via tcp, damit es mit dem dire-wolf-Soundmodem kann "udpflex.exe -U :9002:9001 -T :" (http://home.comcast.net/~wb2osz/site/ geht mit default Einstellung, Sampelrate sollte man aber halbieren sonst ziehts 750MHz CPU)


15. 10. 2014 (Ver 0.43)

  • Input Filtern auf Stichwort im ganzen Frame
  • kleines "e" oder "d" im Map-expansion-Lämpchen zeigt automatischer Map Download off (toggle mit "d"), Manueller Map Reload/Download geht aber auch in dem Modus.
  • Im "F"ind Feld geht auch dezimal Grad "48.2 13.31".
  • bei den Config Zeilen geht "Enter-Taste" als Ok oder Add.
  • Textfarbe vom Items/Objects mit Farbauswähler unabhägnig von normalen Baken einstellbar.
  • Fontgroesse Eingabe zeigt sofort Ergebnis.
  • ist ein Objekt im "show 1" modus, kann man mit "Focus" Karte mitziehen einschalten ohne Watchlisten Eintrag.
  • TAB-Taste schaltet zwischen 2 Kontexten hin und her, dazu zaehlt nebst Wetterkarten-Modi auch der "Focus" Modus, womit 2 Objekte im Bild gehalten werden können.
  • Baken/Message/Ack Senden Warnmeldungen verbessert, wenn der eingestellte Sendepfad vermutlich nicht zum Erfolg fuehrt. (Port ausgeschaltet, nicht zum Senden konfiguriert, kein Passcode am Internet ....)
  • Geländeschnitt, Reichweiten-, Relief-Karten Parameter in ausführlicherem Menü zusammengefasst.
  • Geländeschnitt zeigt freie Meter zum Boden (Karte ziehen zum Messmarke bewegen)
  • Trackfilter beim Suchen auf Duplikate mit Indexsystem so verschnellert, dass beim aus dem Speicher Entfernen von Wegpunkten, auch deren Folgefehler mit Entfernt werden können.


11. 11. 2014 (Ver 0.45)

  • Geländeschnitt und Reliefkarten mit einstellbarem Höhendaten Cache damit Plattenzugriff auf etwa 0.5% verringert.
  • Schalter "kleine/mittlere/volle Aufloesung" entsprechend langsam bis schnell.
  • Interpolation der Hoehendaten und damit brauchbare Bilder bis Zoom 14
  • im "Find" Feld geht Call / Sender of Object / Locator / DDMM.MM / D.DDDD
  • Marker 1 setzen Sendet DDMM.MM zum c/p Buffer, Marker 2 D.DDDDD Format.


9. 12. 2014 (Ver 0.46)

  • Watchcall Popup-Fenster anklickbar und zentriert Map auf das Objekt
  • Point-Of-Interest-File (osm/poi.txt) mit Name/Position/(optional) Hoehe (als Beispiel ist ein File mit etwa 20000 mehr oder weniger richtigen Alpengipfeln vorhanden)
  • mit "F" oder Tools->Find kann mit Wildcards (ste?n*) auf die Namen gesucht werden und die Karte zentriert auf die Position und setzt Marker 1. Bei mehreren passenden Namen mit Enter oder Klick auf Find werden alle Positionen durchgesteppt.
  • ist "p" oder Config->Map Parameter->Show Loc of Mouse auf ON, geht beim Bewegen der Maus eine Sprechblase mit Zeiger zum nächstgelegenen Poi auf. Mit "c" kann die Karte drauf zentriert werden.


30. 12. 2014 (Ver 0.46)

  • Marker 1 und 2 setzen ("x" "y") geht ohne vorher auf die Karte klicken gleiches bei Zentrieren "c" mit dem Unterschied wenn ein POI maximal 5 Pixel entfernt angezeigt wird, exakt auf diesen zentriert wird.


26. 1. 2015 (Ver 0.47)

  • nebst "poi.txt" wird noch "mypoi.txt" gelesen damit beim Update bei Bedarf die selber angelegten Punkte erhalten bleiben. nun auch viele SOTA-Standorte im poi.txt
  • Log File (rawlog) durch Anhaengen von %d zB. "logs/rawlog%d" auf tageweise 1 File mit Datum umstellbar. Ist auch kompatibel zu den Logs am www-Server. (Log Filename jetzt im "File" Menue)
  • Bei tageweisem Log einstellbar nach wieviel Tagen automatisch (beim Start oder Mitternacht) Logs geloescht werden sollen.
  • im Log suchen nach Datum und/oder Call sollte auch dank "Load" (für ab eingegebenen Datum) deutlich zuverlässiger gehen.
  • mehrfach eingetroffene selbe Message wird nur 1x Angezeigt.
  • Baken (Netzbake, Objekte) können Position aus File (auch in Grad mit Komma) lesen fuer bewegliche Objekte oder Mobilbetrieb.
  • Baken können Text-Macro-File löschen nach 1 mal Senden zum Zweck des automatischen Verstummens der Bake wenn zB das Wetterhäuschen nimmer Updatet.


2. 3. 2015 (Ver 0.48)

  • Nur Stationen mit einem bestimmten Symbol aufs Bild, Symbol-Wahl in Tools / Select Data / Symbol>. On/Off mit "Symbol" oder "s"-Taste. Achtung: Screenshot Taste ist jetzt "S".
  • Overlay Symbole mit Mausklick eingebbar


6. 3. 2015 (Ver 0.48)

  • Zoom-Lupe aufziehen mit rechter Maustaste halten. Ohne Maus bewegen wie bisher Backspace in der Zoom/Pan History oder (Copy/)Paste in Texteingaben.


15.3. 2015 (Ver 0.49)

  • Hover Info Popup (Tools/On Next Click/Hover) auf den Symbolen und Glaendeschnitt zu Marker 1 wenn Tools/Radiolink enabled.

24.3. 2015 (Ver 0.49)

  • Linkstreckenberechnung mit einstellbarer Beugung (refraktion) der Hf in der Atmosphaere.


15.6. 2015 (Ver 0.49)

  • "H" fuer Hoehendaten Farbdarstellung.
  • Cache auch fuer nicht vorhandensein von Hoehendaten damits schneller mit Loechern im Datenmaterial zurecht kommt.
  • poi.txt ohne Neustart einlesen mit "Reload Config".
  • Wx Radioaktivitaet dekodieren und (vorerst) als Text ausgeben.


21.6. 2015 (Ver 0.50)


  • Maidenhead Locator Ausgabe langes Format, Eingabe "Find" 6 8 oder 10 stellig.
  • Treiber Aufruf fuer Soundmodems und (USB-)serielle kiss/smack TNC/Funkgeraete betriebssystemspezifisch voreingestellt (sofern noch kein aprsmap.cfg vorhanden ist).
  • Popup Fenster Ueberlappungen etwas seltener.
  • Radioaktivitaet (Sievert) Dekodierung in den Wx-Baken (vorerst ohne Grafik)
  • Getrennte Backspace/Rechte-Maus History fuer beide TABs


27.6. 2015 (Ver 0.50)

  • etwas verbesserte popup Fenster Platzierung.
  • Config > Map Parameter > Reset to Default oder kurz "D" stellt die meisten Bildparameter und Klickverhalten auf Default. Die alten Werte gehen zuvor in die Backspace/rechte Maus-History zwecks Undo der Funktion.
  • History/TAB speichert die wichtigsten Bildparameter + Kartentyp.


6. 7. 2015 (Ver 0.52)

  • Parameter Reset "ctrl-L" statt "D"
  • dekodieren und darstellen vom Area-Objects, Kreis, Ellypse, Rechteck, Dreieck, Linie (ohne Corridor) gefuellt oder leer in 8 Farben nach APRS101.pdf.
  • Baken Editor erstmal fuer numerische Eingabe der Area Objects.
  • dekodieren und darstellen von Multiline-Objects mit 3 Linientypen und 4 Farben nach AE5PL 1-23 Linien pro Bake geschlossen oder offen.
  • Anklicken aller Linien und Flaechen am Rand und Verhalten wie normale Objekte aber ohne Track bei Bewegung.


8. 7. 2015 (Ver 0.52)

  • Multiline-Objekt Editor


25. 8. 2015 (Ver 0.54)

  • Mic-e-Telemetrie Dekoder, die Herstellercodes aus den Mic-e Frames werden dazu vorher entfernt (soweit es geht) was auch sauberere Kommentarzeilen ergibt.


16.10. 2015 (Ver 0.56)

  • Wetterbake (Netbeacon, Rf Beacon, Query) aus .csv File
 \\!wx.csv,,,t,,,,,h,b,r,w,d,,,,,g! im comment extrahiert die Werte aus der letzten Zeile
 im File wx.csv. Es kann noch ein Multiplikator angegeben werden zb. ,w3.6, statt ,w, zum
 Umrechnen von m/s auf km/h. Werte siehe Hints. Wx Symbol auswaehlen.
  • Messages/Queries bei 9-stelligem Mycall sollten nun bestaetigt/beantwortet werden.


24.11. 2015 (Ver 0.58)

  • Wx Grafiken korrigiert
  • Schaltknopf/Laempchen fuer Objekte Ein/Aus
  • Gate Net-to-Rf mit Radius und Bit/s Limit und Option nur Message zu (gehoerten) Usern (mit Standard-3rd-party Protokoll und ohne speichern/wiederholen von Messages). Einschalten mit Config/Rf-Ports/Digipeater, Rx auf "N", Bit/s in "N-n Words" siehe Hints.


28.11. 2015 (Ver 0.58)

  • Starten ohne "terminal" und Abstellen sollte ohne X11 abschmieren gehen.
  • UDP Ports an und abschalten auch mit laufendem "serial interface".


29.11. 2015 (Ver 0.58)

  • History bei der "Find" Zeile mit Cursor up/down.
  • Rf-Monitor mit Txdelay, Level und Quality, sofern vom Modem geliefert (afskmodem linux).
  • Fenster Kopfzeile "nur neue" Calls (Config/rf-ports/monitor headline 0) und Zeit seit letztem mal gehört(1).


7. 1. 2016 (Ver 0.59)

  • "Storm Data" Auswertung und Flächen-Darstellung mit interpolierter Animation. (mangels Aktueller Testdaten nach APRS101.pdf in nautischen Meilen 1.609km)
  • Area-, Multiline-, Sturm-Objekte mit "<>" durchsteppen mit zum Wegpunkt gehörender Flächendarstellung.


23.1.2016 (Ver 0.59)

  • Item in Messages, (B)akeneditor (auf "Item") + (M)essage Send Fenster geöffnet kopiert den Bakeninhalt in Message Text und erzeugt dann beim Empfaenger der Msg ein Symbol auf der Karte. (APRS1.2) Da sich die Protokollerweiterung Item-Message und Multiline-Object gegenseitig beissen ("{" symbol), geht die Kombination vermutlich nur mit aprsmap + send with ack.


25.5.2016 (Ver 0.61)

  • Objekte ohne Richtung und Geschwindigkeit zeichnen keinen Track mehr.
  • alle alternativ Symbole koennen Overlay Zeichen haben (a..z A..Z 0..9)
  • Hamnet Symbol in symbols.png


15.3.2017 (Ver 0.64)

  • Trackfilter geht bei mehr als 15000 Wegpunkten nimmer gegen Rechenzeit unendlich.
  • Trackfilter wird auch mit den kleinen Zappeleien bei Verzoegerungen unter 1Min fertig.
  • "Find Item Message" zeigt auch bei mehreren solchen Msgs die dazu passende Position.


5.4.2017 (Ver 0.65)

  • Rotes Fehlermeldung-Popupfenster groesser und umfangreicher bei der Baken Eingabe.
  • mit []-Tasten Zeit aendern wie lang Dinge auf der Karte sichtbar bleiben.


25.5.2017 (Ver 0.66)

  • Kontrast der Symbole verbessert.
  • Fenster zu klicken sollte bei vielen Linux-Fenstermachern wieder geeordnet abstellen.
  • Linux 64bit Version.


5.7.2017 (Ver 0.67)

  • langen Locator suchen korrigiert und Kleinfeld Darstellung
  • udpflex (linux) tcpkiss server


29.9.2017 (Ver 0.69)

  • Helligkeitskorrektur (Tools > Add Maptypes) als Gamma Werte statt +- Helligkeit. Bei Bildschirm-Gamma (Config > Brightness) 2.2 entspricht 0.45 original und 0.3 etwa dem bisherigen -128. Die Werte werden nun bei Kontextumschaltung mit TAB mit dem Kartentyp gespeichert.


01.12.2017 (Ver 0.70)

  • Kartentypen mit Gamma-Korrektur statt Helligkeitskorrektur. (Tools > Add Maptypes) solang ein Hellikeitswert konfiguriert ist, wird default 0.25 angewendet. (Sinn der Sache: Sat Map von Sentinel2)
  • Eingestellte Karten Helligkeiten werden individuell für Kartentype gespeichert. (Sat Maps sind bei 100% ok, OSM karten eher bei 20 bis 40%)
  • "6" schaltet alle aktiven Kartentypen im kreisrum durch.
  • Font von 7x6 bis 24x12 und zoombare Symbole 16 bis 32 aus symbol file 16 bis 48 Track und Wegpunkte werden mit angepasst. (Zweck: hochaufloesende Bildschirme)
  • Neue Fontfiles und Symbolfile mit teiltransparenten Symbolen (wird noch verschönbessert ...) beim Symbol Zoom wird erst versucht ein zur Grösse passendes symbolsXX.png zu laden falls nicht vorhanden wird "symbols.png" gezoomt.
  • Weicher Alpha-Kanal (Transparenz) bei den Symbolen (win: neue "pngm.dll")


09.12.2017 (Ver 0.71)

  • win: jpegm.dll damit werden auch OSM Karten im jpeg Format gelesen (auch mit Filename *.png)
  • win: getosm.exe (dank an oe5krn) neu mit "getosm.org" start Datei im zip und ohne "getosm.ini" damit bei Programmupdate OSM-urls nimmer überschrieben werden
  • Urls mit .jpg hinten können eingegeben werden
  • Konvertierung auf png kann abgeschaltet bleiben, spart Plattenspeicher


12.02.2018 (Ver 0.72)

  • Logfile laden (besonders mit 270000 Baken Track drin) verschnellert.
  • Symbole-Zoom verbessert und % Eingabe als 3. Parameter bei Config>Font>Fontsize für Symbolgroesse/Texthoehe Verhältnis


15.03.2018 (Ver 0.72)

  • Linux 64bit Copy/Paste Absturz behoben (hoffentlich)
  • Refraction Parameter wirkt auch bei Radiolink Ausleuchtung


12.07.2018 (Ver 0.74)

  • Neue-Version-Check Funktion mit shell/BAT script falls wer einen dazu passenden www-server baut.
  • Radiowellen Ausbreitungsberechnung um Streckendaempfung und Antennendiagramme aus Hersteller-Files erweitert.


07.10.2018 (Ver 0.75)

  • Fehler beim Logfile importieren und nach Uhrzeit sortieren behoben.


12.10.2018 (Ver 0.75)

  • poi.txt aus Hamnet-db und Foto-webcam Daten aktualisiert.
  • "P" rechnet mit Refrac (0.13 Licht, 0.25 Funk)


17.11.2018 (Ver 0.76)

  • Poi-Files mit beliebigen Namen in osm/poi/
  • Darstellung eines Info-Fensters bei Maus nahe einem Poi sofern Info enthalten.
  • Auswahlmenue "C" oder "Tools/Select Data/Show POI" zum Zeichen von einstellbaren Symbolen eines oder mehrere Poi Files. "l" (= kleines "L") schaltet Labels ein/aus. Dazu Text-Filter im Namen oder Infofeld zum eingrenzen der Auswahl mit "*" und "?"
  • Marker setzen mit Fangen der Position des nahen Poi mit "X" und "Y", ohne Fangen "x" "y".


h264 in mpeg4 Container: Linux: 1 mal machen: mknod map.y4m p

      fuer jedes Video starten:  x264 -o film.mp4 --muxer mp4 --crf 22 map.y4m
                                 <Make Video>

win: File / Make Video gibt unkomprimiertes Videofile map.y4m

    (.y4m sollten mplayer oder vlc abspielen koennen)
    klein packen mit x264.exe "x264 -o film.mp4 --muxer mp4 --crf 22 map.y4m"
    (crf=22..27 qualitaet gut bis sparsam)
    vorher mit Animate und auf Map klicken passende Geschwindigkeit einstellen


files/dirs:

 aprsmap           programm
 aprsmap.cfg       beispiel config, wenn nicht vorhanden werden default werte erzeugt
 hints.txt         tipps beim verweilen mit der maus auf buttons
 help.txt          Hyperlink-Hilfetext unter Help > Helptext
 gm.sh             shell script zum osm karten holen 
                   (geht nun auch mit der busybox am tinycore) ./gm.sh 
                   (darf/soll verbessert werden HI) 
 symbols.png       icons
 font.png          buchstaben
 gettiles          vom aprsmap erzeugte liste fehlender map tiles
 rawlog            timestamp+aprsis format wenn vorhanden beim start eingelesen 
                   bei connect zu aprs server kommts neue dazu
                   dargestellt werden die eingestellten minuten vom ende des logs
                   mit connect zu server eingestellte minuten von jetzt
                   file darf editiert, beschnitten, gefiltert werden
                   wird nach timestamp sortiert eingelesen
                   (langes file einlesen geht mit serverconnect schneller
                   da erst ab "jetzt-darstellzeit" decodiert wird)
 osm/tiles/        karten im osm format
 osm/tiles_sat/
 osm/tiles_topo/
 udpflex           axudp<->kiss/smack/flexkiss interface fuer TNC, TMx7xx ...
 kisson.txt        kiss initialisierung fuer TMD72 mit udpflex 
 getosm.exe        Win: Schneller Maplader von OE5KRN
 poi.txt           globales/privates
 mypoi.txt         Points-Of-Interest-File mit aktiviertem "p" zum zeigen bei
                   Mauszeigernaehe oder Suchen mit "F"

oe5dxl


<< Zurück zur DXL-APRSmap Übersicht